Installation

Prerequisites

This guide assumes that you already know how to install and configure Laravel and have the latest version of Composer installed.

Install Botble Core

Step 1: Setup Botble Core as vendor package.

Extract the files from the core.zip you have downloaded from CodeCanyon into a core folder in your project root.

Edit your composer.json file and add a local path repository:

"repositories": [
    {
        "type": "path",
        "url": "./core"
    }
]

In your terminal run:

composer require botble/media *@dev

Step 2: Publish assets file

Publish the assets files with Laravel command:

php artisan vendor:publish --tag=public --force

Step 3: Install Botble Core

php artisan cms:install

Now you can access to admin panel in http://your-project-domain.local/admin.

If you don't want /admin in the URL, please add to .env

ADMIN_DIR=

But make sure you removed default route for "/". It's default welcome page of Laravel or your project.

You can publish the config file with (optional):

php artisan vendor:publish --provider="Botble\Base\Providers\BaseServiceProvider" --tag=config

Head over to the Usage section to get started.

Requirements and Browser Support

Botble Core requires Laravel >= 5.5 and supports the following browsers (desktop and mobile): Chrome, Firefox, Opera, Safari, MS Edge and IE10+.